GitHub Advisoryadvisory · Maven
GHSA-v2rg-8cwr-75g8 Deserializer tampering in Apache Dubbo
CRITICAL
Official page ↗
- Aliases
- CVE-2021-25641
- Ecosystem
- Maven
- Packages
- org.apache.dubbo:dubbo, com.alibaba:dubbo
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2021-06-02
Affected packages
• Maven org.apache.dubbo:dubbo: >= 2.5.0, < 2.7.8 → fixed in 2.7.8
• Maven com.alibaba:dubbo: >= 2.5.0, < 2.6.9 → fixed in 2.6.9
Description
Each Apache Dubbo server will set a serialization id to tell the clients which serialization protocol it is working on. But for Dubbo versions before 2.7.8 or 2.6.9, an attacker can choose which serialization id the Provider will use by tampering with the byte preamble flags, aka, not following the server's instruction. This means that if a weak deserializer such as the Kryo and FST are somehow in code scope (e.g. if Kryo is somehow a part of a dependency), a remote unauthenticated attacker can tell the Provider to use the weak deserializer, and then proceed to exploit it.
Related
Alias · CVE (1)
- CVE-2021-25641 Each Apache Dubbo server will set a serialization id to tell the clients which serialization protocol it is working on. vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness