GitHub Advisoryadvisory · Packagist

GHSA-v2rh-5v88-rgvh Moodle context freezing

MEDIUM Published 2022-05-13 Modified 2025-05-23 Official page ↗
Aliases
CVE-2019-3852
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: >= 3.6, < 3.6.3 → fixed in 3.6.3

Description

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Related

Alias · CVE (1)

  • CVE-2019-3852 A vulnerability was found in moodle before version 3.6.3. vulnerability

References