GitHub Advisoryadvisory · npm
GHSA-v2x8-97xq-8xrr N8N's Chat Trigger component is vulnerable to XSS
HIGH
Official page ↗
- Aliases
- CVE-2025-56265
- Ecosystem
- npm
- Packages
- @n8n/n8n-nodes-langchain
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-434, CWE-79
- Reviewed
- 2025-09-10
Affected packages
• npm @n8n/n8n-nodes-langchain: < 1.107.0 → fixed in 1.107.0
Description
An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3, v1.100.1, and v1.101.1 allows attackers to execute arbitrary code via uploading a crafted HTML file.
Related
Alias · CVE (1)
- CVE-2025-56265 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3, v1.100.1, and v1.101.1 allows attackers to execute… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-56265 advisory
- https://github.com/n8n-io/n8n/pull/18148 web
- https://github.com/n8n-io/n8n package
- https://github.com/n8n-io/n8n/releases/tag/n8n%401.107.0 web
- https://github.com/nikolas-ch/CVEs/blob/main/N8N/N8N_v1.100.1/ChatTrigger_StoredXSSviaUnrestrictedFileUpload/StoredXSSviaUnristrictedFileUpload.txt web