GitHub Advisoryadvisory · PyPI
GHSA-v342-4xr9-x3q3 Frappe has Possibility of Remote Code Execution due to improper validation
MEDIUM
Official page ↗
- Aliases
- CVE-2025-30213
- Ecosystem
- PyPI
- Packages
- frappe
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- Weaknesses
- CWE-20
- Reviewed
- 2025-03-25
Affected packages
• PyPI frappe: < 14.91.0 → fixed in 14.91.0
• PyPI frappe: >= 15.0.0, < 15.52.0 → fixed in 15.52.0
Description
Impact
A system user was able to create certain documents in a specific way that could lead to RCE.
Workarounds
There's no workaround, an upgrade is required.
Credits
Thanks to Thanh of Calif.io for reporting the issue
Related
Alias · CVE (1)
- CVE-2025-30213 Frappe is a full-stack web application framework. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness