GitHub Advisoryadvisory · PyPI

GHSA-v3c5-jqr6-7qm8 Python Charmers Future denial of service vulnerability

HIGH Published 2022-12-23 Modified 2025-04-15 Official page ↗
Aliases
CVE-2022-40899
Ecosystem
PyPI
Packages
future
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2023-01-04

Affected packages

• PyPI future: < 0.18.3 → fixed in 0.18.3

Description

An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server. This issue has been patched in version 0.18.3.

Related

Alias · CVE (1)

  • CVE-2022-40899 An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References