GitHub Advisoryadvisory · PyPI

GHSA-v3c8-3pr6-gr7p llama_index vulnerable to SQL Injection

CRITICAL Published 2025-06-05 Modified 2026-07-21 Official page ↗
Aliases
CVE-2025-1793
Ecosystem
PyPI
Packages
llama-index
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2025-06-06

Affected packages

• PyPI llama-index: < 0.12.28 → fixed in 0.12.28

Description

Multiple vector store integrations in run-llama/llama_index version v0.12.21 have SQL injection vulnerabilities. These vulnerabilities allow an attacker to read and write data using SQL, potentially leading to unauthorized access to data of other users depending on the usage of the llama-index library in a web application.

Related

Alias · CVE (1)

  • CVE-2025-1793 Multiple vector store integrations in run-llama/llama_index version v0.12.21 have SQL injection vulnerabilities. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References