GitHub Advisoryadvisory · PyPI

GHSA-v3m2-pg96-w33m Openstack cinder Improper handling of ScaleIO backend credentials

HIGH Published 2022-05-24 Modified 2024-11-18 Official page ↗
Aliases
CVE-2020-10755
Ecosystem
PyPI
Packages
cinder, os-brick
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-522
Reviewed
2024-04-29

Affected packages

• PyPI cinder: >= 14.0.0, < 14.1.0 → fixed in 14.1.0 • PyPI cinder: >= 15.0.0, < 15.2.0 → fixed in 15.2.0 • PyPI cinder: >= 16.0.0, < 16.1.0 → fixed in 16.1.0 • PyPI os-brick: >= 2.8.0, < 2.8.6 → fixed in 2.8.6 • PyPI os-brick: >= 2.10.0, < 2.10.4 → fixed in 2.10.4 • PyPI os-brick: >= 3.0.0, < 3.0.2 → fixed in 3.0.2

Description

An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the ``connection_info`` element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project

Related

Alias · CVE (1)

  • CVE-2020-10755 An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x… vulnerability

Weakness · CWE (1)

  • CWE-522 Insufficiently Protected Credentials weakness

References