GitHub Advisoryadvisory · Packagist

GHSA-v3wp-35g3-m9mm Moodle does not consider the moodle/tag:flag capability

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-2271
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: < 2.6.9 → fixed in 2.6.9 • Packagist moodle/moodle: >= 2.7.0, < 2.7.6 → fixed in 2.7.6 • Packagist moodle/moodle: >= 2.8.0, < 2.8.4 → fixed in 2.8.4

Description

tag/user.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/tag:flag capability before proceeding with a flaginappropriate action, which allows remote authenticated users to bypass intended access restrictions via the "Flag as inappropriate" feature.

Related

Alias · CVE (1)

  • CVE-2015-2271 tag/user.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/tag:flag… vulnerability

References