GitHub Advisoryadvisory · npm

GHSA-v3xr-g6p2-fvgv Ghost: Stored XSS via oEmbed Photo Responses

HIGH Published 2026-10-07 Modified 2026-10-07 Official page ↗
Aliases
CVE-2026-105650
Ecosystem
npm
Packages
ghost
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-184, CWE-79
Reviewed
2026-10-07

Affected packages

• npm ghost: >= 2.5.0, < 6.64.0 → fixed in 6.64.0

Description

Impact Embedding a URL from an attacker-controlled website could result in untrusted scripts being stored in post content. These scripts could run in the Ghost editor, on the published site, and in newsletter emails, possibly resulting in compromise of a staff user's admin session. Vulnerable versions This vulnerability is present in Ghost from v2.1.0 up to v6.64.0. Patches v6.64.0 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. References Ghost thanks SecBuddyF of Tencent KeenLab and Nhat Anh Vu for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email us at [email protected].

Related

Alias · CVE (1)

  • CVE-2026-105650 Ghost is a Node.js content management system. vulnerability

Weakness · CWE (2)

  • CWE-184 Incomplete List of Disallowed Inputs weakness
  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References