GitHub Advisoryadvisory · Maven
GHSA-v46q-xjp5-7p6r Stored XSS vulnerability in Jenkins Cadence vManager Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2243
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:vmanager-plugin
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-20
Affected packages
• Maven org.jenkins-ci.plugins:vmanager-plugin: < 3.0.5 → fixed in 3.0.5
Description
Jenkins Cadence vManager Plugin 3.0.4 and earlier does not escape build descriptions in tooltips, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission.
Cadence vManager Plugin 3.0.5 removes affected tooltips.
Related
Alias · CVE (1)
- CVE-2020-2243 Jenkins Cadence vManager Plugin 3.0.4 and earlier does not escape build descriptions in tooltips, resulting in a stored cross-site… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness