GitHub Advisoryadvisory · PyPI

GHSA-v4f4-23wc-99mh pipreqs vulnerable to Dependency Confusion

CRITICAL Published 2023-06-30 Modified 2024-10-11 Official page ↗
Aliases
CVE-2023-31543
Ecosystem
PyPI
Packages
pipreqs
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-427
Reviewed
2023-06-30

Affected packages

• PyPI pipreqs: >= 0.3.0, < 0.4.12 → fixed in 0.4.12

Description

A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the chosen repository server.

Related

Alias · CVE (1)

  • CVE-2023-31543 A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the… vulnerability

Weakness · CWE (1)

  • CWE-427 Uncontrolled Search Path Element weakness

References