GitHub Advisoryadvisory · RubyGems

GHSA-v4f8-2847-rwm7 Nokogiri Implements libxml2 version vulnerable to use-after-free

HIGH Published 2022-05-24 Modified 2023-07-10 Official page ↗
Aliases
CVE-2021-3518
Ecosystem
RubyGems
Packages
nokogiri
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-416
Reviewed
2023-07-05

Affected packages

• RubyGems nokogiri: < 1.11.4 → fixed in 1.11.4

Description

There's a flaw in libxml2 in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by an application linked with libxml2 could trigger a use-after-free. The greatest impact from this flaw is to confidentiality, integrity, and availability.

Related

Alias · CVE (1)

  • CVE-2021-3518 There's a flaw in libxml2 in versions before 2.9.11. vulnerability

Weakness · CWE (1)

References