GitHub Advisoryadvisory · Maven
GHSA-v4rr-65x6-g69f XXE vulnerability in Jenkins Flaky Test Handler Plugin
HIGH
Official page ↗
- Aliases
- CVE-2022-28140
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:flaky-test-handler
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-611
- Reviewed
- 2022-05-03
Affected packages
• Maven org.jenkins-ci.plugins:flaky-test-handler: < 1.2.2 → fixed in 1.2.2
Description
Jenkins Flaky Test Handler Plugin 1.2.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
Related
Alias · CVE (1)
- CVE-2022-28140 Jenkins Flaky Test Handler Plugin 1.2.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. vulnerability
Weakness · CWE (1)
- CWE-611 Improper Restriction of XML External Entity Reference weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-28140 advisory
- https://github.com/jenkinsci/flaky-test-handler-plugin/commit/c4ab38fef3658a02315a00288b934bdd9981b3a4 web
- https://github.com/jenkinsci/flaky-test-handler-plugin package
- https://www.jenkins.io/security/advisory/2022-03-29/#SECURITY-1896 web
- http://www.openwall.com/lists/oss-security/2022/03/29/1 web