GitHub Advisoryadvisory · PyPI

GHSA-v4w5-p2hg-8fh6 Urllib3 Incorrect Certificate Validation

MEDIUM Published 2022-05-17 Modified 2024-11-18 Official page ↗
Aliases
CVE-2016-9015
Ecosystem
PyPI
Packages
urllib3
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-295
Reviewed
2023-07-31

Affected packages

• PyPI urllib3: >= 1.17, < 1.18.1 → fixed in 1.18.1

Description

Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can cause them, in certain configurations, to not correctly validate TLS certificates. This places users of the library with those configurations at risk of man-in-the-middle and information leakage attacks. This vulnerability affects users using versions 1.17 and 1.18 of the urllib3 library, who are using the optional PyOpenSSL support for TLS instead of the regular standard library TLS backend, and who are using OpenSSL 1.1.0 via PyOpenSSL. This is an extremely uncommon configuration, so the security impact of this vulnerability is low.

Related

Alias · CVE (1)

  • CVE-2016-9015 Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can cause them, in certain configurations, to not… vulnerability

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References