GitHub Advisoryadvisory · RubyGems

GHSA-v58w-6xc2-w799 Puppet Denial of Service and Arbitrary File Write

LOW Published 2022-05-14 Modified 2024-01-12 Official page ↗
Aliases
CVE-2012-1987
Ecosystem
RubyGems
Packages
puppet
Severity
Low
Weaknesses
CWE-400
Reviewed
2024-01-12

Affected packages

• RubyGems puppet: >= 2.6.0, < 2.6.15 → fixed in 2.6.15 • RubyGems puppet: >= 2.7.0, < 2.7.13 → fixed in 2.7.13

Description

A vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys to (1) cause a denial of service (memory consumption) via a REST request to a stream that triggers a thread block, as demonstrated using CVE-2012-1986 and `/dev/random`; or (2) cause a denial of service (filesystem consumption) via crafted REST requests that use "a marshaled form of a `Puppet::FileBucket::File object`" to write to arbitrary file locations.

Related

Alias · CVE (1)

  • CVE-2012-1987 Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x,… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References