GitHub Advisoryadvisory · Packagist

GHSA-v5c9-mmw9-829q PHPMailer susceptible to arbitrary code execution

HIGH Published 2022-05-14 Modified 2022-06-17 Official page ↗
Aliases
CVE-2008-5619
Ecosystem
Packagist
Packages
phpmailer/phpmailer
Severity
High
Weaknesses
CWE-94
Reviewed
2022-06-17

Affected packages

• Packagist phpmailer/phpmailer: < 5.2.10 → fixed in 5.2.10

Description

html2text.php in Chuggnutt HTML to Text Converter, as used in PHPMailer before 5.2.10, RoundCube Webmail (roundcubemail) 0.2-1.alpha and 0.2-3.beta, Mahara, and AtMail Open 1.03, allows remote attackers to execute arbitrary code via crafted input that is processed by the preg_replace function with the eval switch.

Related

Alias · CVE (1)

  • CVE-2008-5619 html2text.php in Chuggnutt HTML to Text Converter, as used in PHPMailer before 5.2.10, RoundCube Webmail (roundcubemail) 0.2-1.alpha and… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References