GitHub Advisoryadvisory · Go
GHSA-v5fm-hr72-27hx Nomad Search API Leaks Information About CSI Plugins
MEDIUM
Official page ↗
- Aliases
- CVE-2023-3300
- Ecosystem
- Go
- Packages
- github.com/hashicorp/nomad
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-266, CWE-862
- Reviewed
- 2024-04-01
Affected packages
• Go github.com/hashicorp/nomad: >= 0.11.0, < 1.4.11 → fixed in 1.4.11
• Go github.com/hashicorp/nomad: >= 1.5.0, < 1.5.7 → fixed in 1.5.7
Description
A vulnerability was identified in Nomad such that the search HTTP API can reveal names of available CSI plugins to unauthenticated users or users without the plugin:read policy. This vulnerability, CVE-2023-3300, affects Nomad since 0.11 and was fixed in 1.6.0, 1.5.7, and 1.4.11.
Related
Alias · CVE (1)
- CVE-2023-3300 HashiCorp Nomad and Nomad Enterprise 0.11.0 up to 1.5.6 and 1.4.1 HTTP search API can reveal names of available CSI plugins to… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-3300 advisory
- https://github.com/hashicorp/nomad/commit/a8789d3872bbf1b1f420f28b0f7ad8532a41d5e3 web
- https://discuss.hashicorp.com/t/hcsec-2023-22-nomad-search-api-leaks-information-about-csi-plugins/56272 web
- https://github.com/hashicorp/nomad package
- https://pkg.go.dev/vuln/GO-2024-2671 web