GitHub Advisoryadvisory · PyPI
GHSA-v5hv-4pw3-q6h9 ADMesh improper array index validation
HIGH
Official page ↗
- Aliases
- CVE-2022-38072
- Ecosystem
- PyPI
- Packages
- admesh
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-118, CWE-129
- Reviewed
- 2024-11-22
Affected packages
• PyPI admesh: < 0.98.5 → fixed in 0.98.5
Description
An improper array index validation vulnerability exists in the stl_fix_normal_directions functionality of ADMesh Master Commit 767a105 and v0.98.4. A specially-crafted stl file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.
Related
Alias · CVE (1)
- CVE-2022-38072 An improper array index validation vulnerability exists in the stl_fix_normal_directions functionality of ADMesh Master Commit 767a105 and… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-38072 advisory
- https://github.com/admesh/admesh/commit/5fab257268a0ee6f832c18d72af89810a29fbd5f web
- https://github.com/admesh/python-admesh package
- https://github.com/pypa/advisory-database/tree/main/vulns/admesh/PYSEC-2023-263.yaml web
- https://talosintelligence.com/vulnerability_reports/TALOS-2022-1594 web