GitHub Advisoryadvisory · PyPI

GHSA-v5rq-w2xm-7g5f Improper Access Control in MySQL Connector Python

HIGH Published 2022-05-13 Modified 2022-06-27 Official page ↗
Aliases
CVE-2019-2435
Ecosystem
PyPI
Packages
mysql-connector-python
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-284
Reviewed
2022-06-27

Affected packages

• PyPI mysql-connector-python: >= 8.0.0, < 8.0.19 → fixed in 8.0.19 • PyPI mysql-connector-python: >= 2.1.0, <= 2.1.8 (no fix yet)

Description

Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/Python). Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connectors. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all MySQL Connectors accessible data as well as unauthorized access to critical data or complete access to all MySQL Connectors accessible data.

Related

Alias · CVE (1)

  • CVE-2019-2435 Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/Python). vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References