GitHub Advisoryadvisory · npm, Packagist, NuGet

GHSA-v626-r774-j7f8 TinyMCE vulnerable to mutation Cross-site Scripting via special characters in unescaped text nodes

MEDIUM Published 2023-11-15 Modified 2023-11-15 Official page ↗
Aliases
CVE-2023-48219
Ecosystem
npm, Packagist, NuGet
Packages
tinymce, tinymce/tinymce, TinyMCE
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-11-15

Affected packages

• npm tinymce: < 5.10.9 → fixed in 5.10.9 • npm tinymce: >= 6.0.0, < 6.7.3 → fixed in 6.7.3 • Packagist tinymce/tinymce: < 5.10.9 → fixed in 5.10.9 • Packagist tinymce/tinymce: >= 6.0.0, < 6.7.3 → fixed in 6.7.3 • NuGet TinyMCE: < 5.10.9 → fixed in 5.10.9 • NuGet TinyMCE: >= 6.0.0, < 6.7.3 → fixed in 6.7.3

Description

Impact A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo/redo functionality and other APIs and plugins. Text nodes within specific parents are not escaped upon serialization according to the HTML standard. If such text nodes contain a special character reserved as an internal marker, they can be combined with other HTML patterns to form malicious snippets. These snippets pass the initial sanitisation layer when the content is parsed into the editor body, but can trigger XSS when the special internal marker is removed from the content and re-parsed. Such mutations occur when serialised HTML content is processed before being stored in the undo stack, or when the following APIs and plugins are used: • `tinymce.Editor.getContent({ format: 'raw' })` • `tinymce.Editor.resetContent()` • Autosave Plugin Patches This vulnerability has been patched in TinyMCE 6.7.3 by: • ensuring that any unescaped text nodes which contain the special internal marker are emptied before removing the marker from the rest of the HTML, and • removing the special internal marker from content strings passed to `Editor.setContent`, `Editor.insertContent`, and `Editor.resetContent` APIs to prevent them from being loaded into the editor as user-provided content. Fix To avoid this vulnerability: • Upgrade to TinyMCE 6.7.3 or higher for TinyMCE 6.x. • Upgrade to TinyMCE 5.10.9 or higher for TinyMCE 5.x. Acknowledgements Tiny Technologies would like to thank Masato Kinugawa of Cure53 for discovering this vulnerability. References • TinyMCE 5.10.9 Release Notes • TinyMCE 6.7.3 Release Notes For more information Email us at [email protected] Open an issue in the TinyMCE repo

Related

Alias · CVE (1)

  • CVE-2023-48219 TinyMCE is an open source rich text editor. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References