GitHub Advisoryadvisory · npm
GHSA-v633-x5vv-hqwc Cross-Site Scripting in serve-index
MEDIUM
Official page ↗
- Aliases
- CVE-2015-8856
- Ecosystem
- npm
- Packages
- serve-index
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• npm serve-index: < 1.6.3 → fixed in 1.6.3
Description
Versions 1.6.2 and earlier of `serve-index` are affected by a cross-site scripting vulnerability. Because file and directory names are not escaped in the module's HTML output, a remote attacker that can influence file or directory names can launch a persistent cross-site scripting attack on the application.
Recommendation
Update to version 1.6.3 or later.
Related
Alias · CVE (1)
- CVE-2015-8856 Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-8856 advisory
- https://github.com/expressjs/serve-index/issues/28 web
- https://github.com/expressjs/serve-index/commit/7381a1d1458959e57ee53ac932b06ff17904777e web
- https://github.com/expressjs/serve-index package
- https://web.archive.org/web/20200227190911/http://www.securityfocus.com/bid/96392 web
- http://www.openwall.com/lists/oss-security/2016/04/20/11 web