GitHub Advisoryadvisory · npm, NuGet, Packagist
GHSA-v65r-p3vv-jjfv TinyMCE mXSS vulnerability in undo/redo, getContent API, resetContent API, and Autosave plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2023-45818
- Ecosystem
- npm, NuGet, Packagist
- Packages
- tinymce, TinyMCE, tinymce/tinymce
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-10-19
Affected packages
• npm tinymce: >= 6.0.0, < 6.7.1 → fixed in 6.7.1
• NuGet TinyMCE: >= 6.0.0, < 6.7.1 → fixed in 6.7.1
• Packagist tinymce/tinymce: >= 6.0.0, < 6.7.1 → fixed in 6.7.1
• npm tinymce: < 5.10.8 → fixed in 5.10.8
• NuGet TinyMCE: < 5.10.8 → fixed in 5.10.8
• Packagist tinymce/tinymce: < 5.10.8 → fixed in 5.10.8
Description
Impact
A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo and redo functionality. When a carefully-crafted HTML snippet passes the XSS sanitisation layer, it is manipulated as a string by internal trimming functions before being stored in the undo stack. If the HTML snippet is restored from the undo stack, the combination of the string manipulation and reparative parsing by either the browser's native DOMParser API (TinyMCE 6) or the SaxParser API (TinyMCE 5) mutates the HTML maliciously, allowing an XSS payload to be executed.
This vulnerability also impacts these related TinyMCE APIs and plugins:
• `tinymce.Editor.getContent({ format: 'raw' })`
• `tinymce.Editor.resetContent()`
• Autosave Plugin
Patches
This vulnerability has been patched in TinyMCE 5.10.8 and TinyMCE 6.7.1 by ensuring HTML is trimmed using node-level manipulation instead of string manipulation.
Fix
To avoid this vulnerability:
• Upgrade to TinyMCE 5.10.8 or higher for TinyMCE 5.x.
• Upgrade to TinyMCE 6.7.1 or higher for TinyMCE 6.x.
Acknowledgements
Tiny Technologies would like to thank Masato Kinugawa of Cure53 for discovering this vulnerability.
References
• TinyMCE 5.10.8 Release Notes
• TinyMCE 6.7.1 Release Notes
For more information
If you have any questions or comments about this advisory:
• Email us at
• Open an issue in the TinyMCE repo
Related
Alias · CVE (1)
- CVE-2023-45818 TinyMCE is an open source rich text editor. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/tinymce/tinymce/security/advisories/GHSA-v65r-p3vv-jjfv web
- https://nvd.nist.gov/vuln/detail/CVE-2023-45818 advisory
- https://github.com/tinymce/tinymce package
- https://researchgate.net/publication/266654651_mXSS_attacks_Attacking_well-secured_web-applications_by_using_innerHTML_mutations web
- https://tiny.cloud/docs/release-notes/release-notes5108/#securityfixes web
- https://tiny.cloud/docs/tinymce/6/6.7.1-release-notes/#security-fixes web
- https://www.tiny.cloud/docs/api/tinymce.html/tinymce.html.saxparser web