GitHub Advisoryadvisory · Maven
GHSA-v67x-gpg7-mwv3 Exposure of Sensitive Information in Jenkins Kubernetes Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000187
- Ecosystem
- Maven
- Packages
- org.csanchez.jenkins.plugins:kubernetes
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2022-11-03
Affected packages
• Maven org.csanchez.jenkins.plugins:kubernetes: < 1.7.1 → fixed in 1.7.1
Description
A exposure of sensitive information vulnerability exists in Jenkins Kubernetes Plugin 1.7.0 and older in ContainerExecDecorator.java that results in sensitive variables such as passwords being written to logs.
Related
Alias · CVE (1)
- CVE-2018-1000187 A exposure of sensitive information vulnerability exists in Jenkins Kubernetes Plugin 1.7.0 and older in ContainerExecDecorator.java that… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness