GitHub Advisoryadvisory · Maven

GHSA-v682-8vv8-vpwr Denial of Service via incomplete cleanup vulnerability in Apache Tomcat

MEDIUM Published 2024-03-13 Modified 2025-08-08 Official page ↗
Aliases
CVE-2024-23672
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-websocket, org.apache.tomcat.embed:tomcat-embed-websocket
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-459
Reviewed
2024-03-14

Affected packages

• Maven org.apache.tomcat:tomcat-websocket: >= 11.0.0-M1, < 11.0.0-M17 → fixed in 11.0.0-M17 • Maven org.apache.tomcat:tomcat-websocket: >= 10.1.0-M1, < 10.1.19 → fixed in 10.1.19 • Maven org.apache.tomcat:tomcat-websocket: >= 9.0.0-M1, < 9.0.86 → fixed in 9.0.86 • Maven org.apache.tomcat:tomcat-websocket: >= 8.5.0, < 8.5.99 → fixed in 8.5.99 • Maven org.apache.tomcat.embed:tomcat-embed-websocket: >= 11.0.0-M1, < 11.0.0-M17 → fixed in 11.0.0-M17 • Maven org.apache.tomcat.embed:tomcat-embed-websocket: >= 10.1.0-M1, < 10.1.19 → fixed in 10.1.19 • Maven org.apache.tomcat.embed:tomcat-embed-websocket: >= 9.0.0-M1, < 9.0.86 → fixed in 9.0.86 • Maven org.apache.tomcat.embed:tomcat-embed-websocket: >= 8.5.0, < 8.5.99 → fixed in 8.5.99

Description

Denial of Service via incomplete cleanup vulnerability in Apache Tomcat. It was possible for WebSocket clients to keep WebSocket connections open leading to increased resource consumption.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Related

Alias · CVE (1)

  • CVE-2024-23672 Denial of Service via incomplete cleanup vulnerability in Apache Tomcat. vulnerability

Weakness · CWE (1)

  • CWE-459 Incomplete Cleanup weakness

References