GitHub Advisoryadvisory · npm

GHSA-v6c6-vqqg-w888 OpenClaw affected by potential code execution via unsafe hook module path handling in Gateway

HIGH Published 2026-02-18 Modified 2026-03-06 Official page ↗
Aliases
CVE-2026-28456
Ecosystem
npm
Packages
openclaw
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-22, CWE-427
Reviewed
2026-02-18

Affected packages

• npm openclaw: >= 2026.1.5, < 2026.2.14 → fixed in 2026.2.14

Description

Summary OpenClaw Gateway supports hook mappings with optional JavaScript/TypeScript transform modules. In affected versions, the gateway did not sufficiently constrain configured module paths before passing them to dynamic `import()`. Under some configurations, a user who can modify gateway configuration could cause the gateway process to load and execute an unintended local module. Impact Potential code execution in the OpenClaw gateway Node.js process. This requires access that can modify gateway configuration (for example via the gateway config endpoints). Treat such access as high privilege. Affected Packages / Versions • npm package: `openclaw` • Affected: `>= 2026.1.5` and `= 2026.2.14` Fix Commit(s) • `a0361b8ba959e8506dc79d638b6e6a00d12887e4` (restrict hook transform module loading) • `35c0e66ed057f1a9f7ad2515fdcef516bd6584ce` (harden hooks module loading) Mitigation • Upgrade to `2026.2.14` or newer. • Avoid exposing gateway configuration endpoints to untrusted networks. • Review config for unsafe values: • `hooks.mappings[].transform.module` • `hooks.internal.handlers[].module` Thanks @222n5 for reporting.

Related

Alias · CVE (1)

  • CVE-2026-28456 OpenClaw versions 2026.1.5 prior to 2026.2.14 contain a vulnerability in the Gateway in which it does not sufficiently constrain configured… vulnerability

Weakness · CWE (2)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
  • CWE-427 Uncontrolled Search Path Element weakness

References