GitHub Advisoryadvisory · Packagist

GHSA-v6f4-v8h8-3c87 Moodle Remote Code Execution vulnerability

HIGH Published 2024-11-07 Modified 2024-11-07 Official page ↗
Aliases
CVE-2024-43425
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2024-11-07

Affected packages

• Packagist moodle/moodle: < 4.1.12 → fixed in 4.1.12 • Packagist moodle/moodle: >= 4.2.0-beta, < 4.2.9 → fixed in 4.2.9 • Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.6 → fixed in 4.3.6 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.2 → fixed in 4.4.2

Description

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References