GitHub Advisoryadvisory · RubyGems
GHSA-v6gp-9mmm-c6p5 Out-of-bounds Write in zlib affects Nokogiri
HIGH
Official page ↗
- Ecosystem
- RubyGems
- Packages
- nokogiri
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-787
- Reviewed
- 2022-04-11
Affected packages
• RubyGems nokogiri: < 1.13.4 → fixed in 1.13.4
Description
Summary
Nokogiri v1.13.4 updates the vendored zlib from 1.2.11 to 1.2.12, which addresses CVE-2018-25032. That CVE is scored as CVSS 7.4 "High" on the NVD record as of 2022-04-05.
Please note that this advisory only applies to the CRuby implementation of Nokogiri `= v1.13.4`.
Impact
CVE-2018-25032 in zlib
• Severity: High
• Type: CWE-787 Out of bounds write
• Description: zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if the input has many distant matches.
Related
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness
References
- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-v6gp-9mmm-c6p5 web
- https://nvd.nist.gov/vuln/detail/CVE-2018-25032 advisory
- https://github.com/advisories/GHSA-jc36-42cf-vqwj advisory
- https://github.com/sparklemotion/nokogiri package
- https://github.com/sparklemotion/nokogiri/releases/tag/v1.13.4 web
- https://groups.google.com/g/ruby-security-ann/c/vX7qSjsvWis/m/TJWN4oOKBwAJ?utm_medium=email&utm_source=footer web