GitHub Advisoryadvisory · npm

GHSA-v6h2-p8h4-qcjw brace-expansion Regular Expression Denial of Service vulnerability

LOW Published 2025-06-09 Modified 2025-06-11 Official page ↗
Aliases
CVE-2025-5889
Ecosystem
npm
Packages
brace-expansion
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-400
Reviewed
2025-06-10

Affected packages

• npm brace-expansion: >= 2.0.0, < 2.0.2 → fixed in 2.0.2 • npm brace-expansion: >= 1.0.0, < 1.1.12 → fixed in 1.1.12 • npm brace-expansion: >= 3.0.0, < 3.0.1 → fixed in 3.0.1 • npm brace-expansion: >= 4.0.0, < 4.0.1 → fixed in 4.0.1

Description

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is `a5b98a4f30d7813266b221435e1eaaf25a1b0ac5`. It is recommended to upgrade the affected component.

Related

Alias · CVE (1)

  • CVE-2025-5889 A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References