GitHub Advisoryadvisory · npm

GHSA-v6mg-96c6-gmpq CKEditor: Cross-site scripting (XSS) in the engine package

LOW Published 2026-10-27 Modified 2026-10-27 Official page ↗
Aliases
CVE-2026-116687
Ecosystem
npm
Packages
ckeditor5, @ckeditor/ckeditor5-engine
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-79
Reviewed
2026-10-27

Affected packages

• npm ckeditor5: >= 29.0.0, < 47.7.4 → fixed in 47.7.4 • npm @ckeditor/ckeditor5-engine: >= 29.0.0, < 47.7.4 → fixed in 47.7.4 • npm ckeditor5: >= 48.0.0, < 48.5.1 → fixed in 48.5.1 • npm @ckeditor/ckeditor5-engine: >= 48.0.0, < 48.5.1 → fixed in 48.5.1

Description

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor. This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content. Patches The problem has been recognized and patched. The fix will be available in version `48.5.1` (and above) and `47.7.4` (LTS). For more information Email us at [email protected] if you have any questions or comments about this advisory.

Related

Alias · CVE (1)

  • CVE-2026-116687 CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References