GitHub Advisoryadvisory · PyPI
GHSA-v798-mcc6-2m3m Langflow: Code Injection Vulnerability in Code Validation Endpoint
CRITICAL
Official page ↗
- Aliases
- CVE-2026-7873
- Ecosystem
- PyPI
- Packages
- langflow
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2026-10-23
Affected packages
• PyPI langflow: >= 1.0.0, < 1.10.1.rc0 → fixed in 1.10.1.rc0
Description
IBM Langflow OSS 1.0.0 through 1.10.0 allows authenticated attackers to execute arbitrary OS commands and read sensitive files including credentials, enabling complete system compromise and lateral movement.
Related
Alias · CVE (1)
- CVE-2026-7873 IBM Langflow OSS 1.0.0 through 1.10.0 allows authenticated attackers to execute arbitrary OS commands and read sensitive files including… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-7873 advisory
- https://github.com/langflow-ai/langflow/pull/13696 web
- https://github.com/langflow-ai/langflow/commit/e7c33dbaade20b5295c7fa26bf83cc1ff68fba02 web
- https://github.com/langflow-ai/langflow package
- https://github.com/langflow-ai/langflow/releases/tag/1.10.1.rc0 web
- https://www.ibm.com/support/pages/node/7278441 web