GitHub Advisoryadvisory · PyPI

GHSA-v7q8-wvvh-c97p Moderate severity vulnerability that affects Zope2

MEDIUM Published 2018-07-23 Modified 2020-06-16 Official page ↗
Aliases
CVE-2010-1104
Ecosystem
PyPI
Packages
Zope2
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• PyPI Zope2: >= 2.8.0, < 2.8.12 → fixed in 2.8.12 • PyPI Zope2: >= 2.9.0, < 2.9.12 → fixed in 2.9.12 • PyPI Zope2: >= 2.10.0, < 2.10.11 → fixed in 2.10.11 • PyPI Zope2: >= 2.11.0, < 2.11.6 → fixed in 2.11.6 • PyPI Zope2: >= 2.12.0, < 2.12.3 → fixed in 2.12.3

Description

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Related

Alias · CVE (1)

  • CVE-2010-1104 Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References