GitHub Advisoryadvisory · Maven

GHSA-v853-w46p-fv2h Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue

HIGH Published 2026-06-01 Modified 2026-07-09 Official page ↗
Aliases
CVE-2026-45505
Ecosystem
Maven
Packages
org.apache.activemq:activemq-broker, org.apache.activemq:activemq-all, org.apache.activemq:apache-activemq
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2026-07-09

Affected packages

• Maven org.apache.activemq:activemq-broker: < 5.19.7 → fixed in 5.19.7 • Maven org.apache.activemq:activemq-broker: >= 6.0.0, < 6.2.6 → fixed in 6.2.6 • Maven org.apache.activemq:activemq-all: < 5.19.7 → fixed in 5.19.7 • Maven org.apache.activemq:activemq-all: >= 6.0.0, < 6.2.6 → fixed in 6.2.6 • Maven org.apache.activemq:apache-activemq: < 5.19.7 → fixed in 5.19.7 • Maven org.apache.activemq:apache-activemq: >= 6.0.0, < 6.2.6 → fixed in 6.2.6

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. Non-parenthesized discovery wrappers such as `masterslave:vm://...,...` and `static:vm://...` incorrectly pass validation allowing bypass of fix in CVE-2026-34197.  Original description from CVE-2026-34197. Apache ActiveMQ exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery UR that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2026-45505 Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References