GitHub Advisoryadvisory · RubyGems

GHSA-v882-ccj6-jc48 Rack vulnerable to Denial of Service

MEDIUM Published 2022-05-05 Modified 2023-03-08 Official page ↗
Aliases
CVE-2013-0184
Ecosystem
RubyGems
Packages
rack
Severity
Moderate
Reviewed
2023-03-08

Affected packages

• RubyGems rack: >= 1.1.0, < 1.1.5 → fixed in 1.1.5 • RubyGems rack: >= 1.2.0, < 1.2.7 → fixed in 1.2.7 • RubyGems rack: >= 1.3.0, < 1.3.9 → fixed in 1.3.9 • RubyGems rack: >= 1.4.0, < 1.4.4 → fixed in 1.4.4

Description

Unspecified vulnerability in `Rack::Auth::AbstractRequest` in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Related

Alias · CVE (1)

  • CVE-2013-0184 Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x… vulnerability

References