GitHub Advisoryadvisory · PyPI

GHSA-v8gr-m533-ghj9 Vulnerable OpenSSL included in cryptography wheels

LOW Published 2023-09-21 Modified 2023-09-21 Official page ↗
Ecosystem
PyPI
Packages
cryptography
Severity
Low
Reviewed
2023-09-21

Affected packages

• PyPI cryptography: >= 2.5, < 41.0.4 → fixed in 41.0.4

Description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 2.5-41.0.3 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230908.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

References