GitHub Advisoryadvisory · Maven

GHSA-v94h-hvhg-mf9h Spring Framework vulnerable to denial of service

HIGH Published 2023-11-28 Modified 2025-02-13 Official page ↗
Aliases
CVE-2023-34053
Ecosystem
Maven
Packages
org.springframework:spring-webmvc
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Reviewed
2023-11-28

Affected packages

• Maven org.springframework:spring-webmvc: >= 6.0.0, < 6.0.14 → fixed in 6.0.14

Description

In Spring Framework versions 6.0.0 - 6.0.13, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable when all of the following are true: • the application uses Spring MVC or Spring WebFlux • io.micrometer:micrometer-core is on the classpath • an ObservationRegistry is configured in the application to record observations Typically, Spring Boot applications need the org.springframework.boot:spring-boot-actuator dependency to meet all conditions.

Related

Alias · CVE (1)

  • CVE-2023-34053 In Spring Framework versions 6.0.0 - 6.0.13, it is possible for a user to provide specially crafted HTTP requests that may cause a… vulnerability

References