GitHub Advisoryadvisory · PyPI
GHSA-v9hf-5j83-6xpp PyMySQL SQL Injection vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2024-36039
- Ecosystem
- PyPI
- Packages
- pymysql
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2024-05-21
Affected packages
• PyPI pymysql: < 1.1.1 → fixed in 1.1.1
Description
PyMySQL through 1.1.0 allows SQL injection if used with untrusted JSON input because keys are not escaped by `escape_dict`.
Related
Alias · CVE (1)
- CVE-2024-36039 PyMySQL through 1.1.0 allows SQL injection if used with untrusted JSON input because keys are not escaped by escape_dict. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-36039 advisory
- https://github.com/PyMySQL/PyMySQL/commit/521e40050cb386a499f68f483fefd144c493053c web
- https://github.com/PyMySQL/PyMySQL package
- https://github.com/PyMySQL/PyMySQL/releases/tag/v1.1.1 web
- https://lists.debian.org/debian-lts-announce/2024/05/msg00017.html web
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/23VXBV34GFRICCVYZ6KFMSSWY5UEXCF5 web
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/35VOJS3SRJNLQIO7YTZFNM6RWHIHWTMK web