GitHub Advisoryadvisory · Packagist

GHSA-v9m8-9xxp-q492 Auth0-PHP SDK Deserialization of Untrusted Data vulnerability

CRITICAL Published 2025-06-04 Modified 2025-06-04 Official page ↗
Aliases
CVE-2025-48951
Ecosystem
Packagist
Packages
auth0/auth0-php
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H
Weaknesses
CWE-502
Reviewed
2025-06-04

Affected packages

• Packagist auth0/auth0-php: >= 8.0.0-BETA3, < 8.3.1 → fixed in 8.3.1

Description

Overview The Auth0 PHP SDK contains a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Am I Affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0-PHP SDK, versions between 8.0.0-BETA3 to 8.3.0. 2. Applications using the following SDKs that rely on the Auth0-PHP SDK versions between 8.0.0-BETA3 to 8.3.0: a. Auth0/symfony, b. Auth0/laravel-auth0, c. Auth0/wordpress. Fix Upgrade Auth0/Auth0-PHP to 8.3.1. Acknowledgement Okta would like to thank Andreas Forsblom for discovering this vulnerability.

Related

Alias · CVE (1)

  • CVE-2025-48951 Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References