GitHub Advisoryadvisory · PyPI
GHSA-v9pc-9mvp-x87g Pillow Buffer overflow in Jpeg2KEncode.c
HIGH
Official page ↗
- Aliases
- CVE-2016-3076
- Ecosystem
- PyPI
- Packages
- pillow
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-119
- Reviewed
- 2024-04-22
Affected packages
• PyPI pillow: >= 2.5.0, < 3.1.2 → fixed in 3.1.2
Description
Heap-based buffer overflow in the j2k_encode_entry function in Pillow 2.5.0 through 3.1.1 allows remote attackers to cause a denial of service (memory corruption) via a crafted Jpeg2000 file.
Related
Alias · CVE (1)
- CVE-2016-3076 Heap-based buffer overflow in the j2k_encode_entry function in Pillow 2.5.0 through 3.1.1 allows remote attackers to cause a denial of… vulnerability
Weakness · CWE (1)
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-3076 advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=1321929 web
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2017-92.yaml web
- https://github.com/python-pillow/Pillow package
- https://github.com/python-pillow/Pillow/blob/4.1.x/docs/releasenotes/3.1.2.rst web
- https://web.archive.org/web/20200227174644/http://www.securityfocus.com/bid/98042 web
- http://pillow.readthedocs.io/en/4.1.x/releasenotes/3.1.2.html web