GitHub Advisoryadvisory · RubyGems

GHSA-v9v4-7jp6-8c73 rails Cross-site Scripting vulnerability

MEDIUM Published 2017-10-24 Modified 2023-04-20 Official page ↗
Aliases
CVE-2011-2197
Ecosystem
RubyGems
Packages
actionpack, activesupport
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: >= 2.0.0, < 2.3.12 → fixed in 2.3.12 • RubyGems actionpack: >= 3.0.0, < 3.0.8 → fixed in 3.0.8 • RubyGems activesupport: >= 2.0.0, < 2.3.12 → fixed in 2.3.12 • RubyGems activesupport: >= 3.0.0, < 3.0.8 → fixed in 3.0.8

Description

The cross-site scripting (XSS) prevention feature in Ruby on Rails 2.x before 2.3.12, 3.0.x before 3.0.8, and 3.1.x before 3.1.0.rc2 does not properly handle mutation of safe buffers, which makes it easier for remote attackers to conduct XSS attacks via crafted strings to an application that uses a problematic string method, as demonstrated by the sub method.

Related

Alias · CVE (1)

  • CVE-2011-2197 The cross-site scripting (XSS) prevention feature in Ruby on Rails 2.x before 2.3.12, 3.0.x before 3.0.8, and 3.1.x before 3.1.0.rc2 does… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References