GitHub Advisoryadvisory · Packagist
GHSA-vc29-mvwv-wpcq Cross-site scripting (XSS) vulnerability in CakePHP
MEDIUM
Official page ↗
- Aliases
- CVE-2006-4067
- Ecosystem
- Packagist
- Packages
- cakephp/cakephp
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2023-01-09
Affected packages
• Packagist cakephp/cakephp: >= 1.0.1.2708, < 1.1.7.3363 → fixed in 1.1.7.3363
Description
Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary web script or HTML via the URL, which is reflected back in a 404 (\"Not Found\") error page. NOTE: some of these details are obtained from third party information.
Related
Alias · CVE (1)
- CVE-2006-4067 Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness