GitHub Advisoryadvisory · Maven

GHSA-vc39-x7w6-6vj7 Apache Tapestry allows deserialization of untrusted data

CRITICAL Published 2022-12-02 Modified 2022-12-05 Official page ↗
Aliases
CVE-2022-46366
Ecosystem
Maven
Packages
org.apache.tapestry:tapestry-core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2022-12-05

Affected packages

• Maven org.apache.tapestry:tapestry-core: >= 3.0, < 5.0.1 → fixed in 5.0.1

Description

UNSUPPORTED WHEN ASSIGNED Apache Tapestry 3.x allows deserialization of untrusted data, leading to remote code execution. This issue is similar to but distinct from CVE-2020-17531, which applies the the (also unsupported) 4.x version line. NOTE: This vulnerability only affects Apache Tapestry version line 3.x, which is no longer supported by the maintainer. Users are recommended to upgrade to a supported version line of Apache Tapestry.

Related

Alias · CVE (1)

  • CVE-2022-46366 Apache Tapestry 3.x allows deserialization of untrusted data, leading to remote code execution. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References