GitHub Advisoryadvisory · npm

GHSA-vcc3-ghjq-m6fr decode-uri-component: Denial of service via exponential decoding of malformed percent-encoded input

MEDIUM Published 2026-08-31 Modified 2026-08-31 Official page ↗
Aliases
CVE-2026-45822
Ecosystem
npm
Packages
decode-uri-component
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/S:N/AU:Y/R:U/V:D/RE:M/U:Amber
Weaknesses
CWE-1176, CWE-400, CWE-405, CWE-407
Reviewed
2026-08-31

Affected packages

• npm decode-uri-component: < 0.5.0 → fixed in 0.5.0

Description

Impact An attacker who can supply input to `decodeUriComponent()` (directly or via a dependency that uses this package on URL/query/path data) can cause excessive CPU usage and application unresponsiveness. This is an availability issue; there is no known memory corruption, data disclosure, or remote code execution impact. Patches Upgrade to `[email protected]`. Workarounds Limit the size of the input.

Related

Alias · CVE (1)

  • CVE-2026-45822 decode-uri-component through 0.4.1 is vulnerable to denial of service. vulnerability

Weakness · CWE (4)

  • CWE-1176 Inefficient CPU Computation weakness
  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-405 Asymmetric Resource Consumption (Amplification) weakness
  • CWE-407 Inefficient Algorithmic Complexity weakness

References