GitHub Advisoryadvisory · Packagist

GHSA-vcgg-hp4r-87gx Contao Does Not Invalidate Existing Sessions When Password Changes

CRITICAL Published 2022-05-14 Modified 2024-04-25 Official page ↗
Aliases
CVE-2019-10641
Ecosystem
Packagist
Packages
contao/contao, contao/core-bundle, contao/core
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-640
Reviewed
2024-04-25

Affected packages

• Packagist contao/contao: >= 4.0.0, < 4.4.37 → fixed in 4.4.37 • Packagist contao/contao: >= 4.5.0, < 4.7.3 → fixed in 4.7.3 • Packagist contao/core-bundle: >= 4.0.0, < 4.4.37 → fixed in 4.4.37 • Packagist contao/core-bundle: >= 4.5.0, < 4.7.3 → fixed in 4.7.3 • Packagist contao/core: >= 3.0.0, < 3.5.39 → fixed in 3.5.39

Description

Security researcher Ali Razzaq has discovered that existing sessions are not correctly invalidated when a user changes their password in the backend or frontend.

Related

Alias · CVE (1)

  • CVE-2019-10641 Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password. vulnerability

Weakness · CWE (1)

  • CWE-640 Weak Password Recovery Mechanism for Forgotten Password weakness

References