GitHub Advisoryadvisory · npm

GHSA-vcjf-mgcg-jxjq CKEditor 4.0 vulnerability in the HTML Data Processor

MEDIUM Published 2021-05-07 Modified 2023-03-31 Official page ↗
Aliases
CVE-2020-9281
Ecosystem
npm
Packages
ckeditor4
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2021-04-23

Affected packages

• npm ckeditor4: < 4.14.0 → fixed in 4.14.0

Description

A cross-site scripting (XSS) vulnerability in the HTML Data Processor for CKEditor 4.0 before 4.14.0 allows remote attackers to inject arbitrary web script through a crafted "protected" comment (with the cke_protected syntax).

Related

Alias · CVE (1)

  • CVE-2020-9281 A cross-site scripting (XSS) vulnerability in the HTML Data Processor for CKEditor 4.0 before 4.14 allows remote attackers to inject… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References