GitHub Advisoryadvisory · PyPI

GHSA-vcr5-xr9h-mvc5 python-gnupg vulnerable to shell injection

CRITICAL Published 2018-11-06 Modified 2024-10-25 Official page ↗
Aliases
CVE-2014-1929
Ecosystem
PyPI
Packages
python-gnupg
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• PyPI python-gnupg: >= 0.3.5, < 0.3.7 → fixed in 0.3.7

Description

python-gnupg 0.3.5 and 0.3.6 allow for shell injection via a failure to escape backslashes in the `shell_quote()` function. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Related

Alias · CVE (1)

  • CVE-2014-1929 python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References