GitHub Advisoryadvisory · Packagist

GHSA-vf23-f26f-mjj9 Access of Resource Using Incompatible Type ('Type Confusion') in yourls/yourls

CRITICAL Published 2019-09-23 Modified 2026-06-08 Official page ↗
Aliases
CVE-2019-14537
Ecosystem
Packagist
Packages
yourls/yourls
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-843
Reviewed
2020-06-16

Affected packages

• Packagist yourls/yourls: < 1.7.4 → fixed in 1.7.4

Description

Impact YOURLS through 1.7.3 is affected by a type juggling vulnerability in the API component that can result in login bypass. Patches https://github.com/YOURLS/YOURLS/releases/tag/1.7.4 https://github.com/YOURLS/YOURLS/pull/2542 References • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14537 • https://github.com/Wocanilo/CVE-2019-14537 For more information If you have any questions or comments about this advisory: • Open an issue in YOURLS repository

Related

Alias · CVE (1)

  • CVE-2019-14537 YOURLS through 1.7.3 is affected by a type juggling vulnerability in the api component that can result in login bypass. vulnerability

Weakness · CWE (1)

  • CWE-843 Access of Resource Using Incompatible Type weakness

References