GitHub Advisoryadvisory · Packagist
GHSA-vf4w-fg7r-5v94 Improper Certificate Validation in phpseclib
HIGH
Official page ↗
- Aliases
- CVE-2021-30130
- Ecosystem
- Packagist
- Packages
- phpseclib/phpseclib
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-295, CWE-347
- Reviewed
- 2021-04-07
Affected packages
• Packagist phpseclib/phpseclib: >= 3.0.0, < 3.0.7 → fixed in 3.0.7
• Packagist phpseclib/phpseclib: < 2.0.31 → fixed in 2.0.31
Description
phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.
Related
Alias · CVE (1)
- CVE-2021-30130 phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-30130 advisory
- https://github.com/phpseclib/phpseclib/pull/1635 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpseclib/phpseclib/CVE-2021-30130.yaml web
- https://github.com/phpseclib/phpseclib/releases/tag/2.0.31 web
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.7 web
- https://lists.debian.org/debian-lts-announce/2022/11/msg00024.html web
- https://lists.debian.org/debian-lts-announce/2022/11/msg00025.html web