GitHub Advisoryadvisory · Maven
GHSA-vf8h-2wwj-jq22 Privilege escalation in Apache ShenYu
HIGH
Official page ↗
- Aliases
- CVE-2022-42735
- Ecosystem
- Maven
- Packages
- org.apache.shenyu:shenyu-admin
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
- Reviewed
- 2023-02-15
Affected packages
• Maven org.apache.shenyu:shenyu-admin: < 2.5.1 → fixed in 2.5.1
Description
Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu. ShenYu Admin allows low-privilege low-level administrators create users with higher privileges than their own. This issue affects Apache ShenYu: 2.5.0. Upgrade to Apache ShenYu 2.5.1 or apply patch https://github.com/apache/shenyu/pull/3958.
Related
Alias · CVE (1)
- CVE-2022-42735 Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu. vulnerability
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness