GitHub Advisoryadvisory · RubyGems

GHSA-vfm5-rmrh-j26v Possible Content Security Policy bypass in Action Dispatch

LOW Published 2024-12-10 Modified 2025-03-07 Official page ↗
Aliases
CVE-2024-54133
Ecosystem
RubyGems
Packages
actionpack
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Weaknesses
CWE-79
Reviewed
2024-12-10

Affected packages

• RubyGems actionpack: >= 5.2.0, < 7.0.8.7 → fixed in 7.0.8.7 • RubyGems actionpack: >= 7.1.0, < 7.1.5.1 → fixed in 7.1.5.1 • RubyGems actionpack: >= 7.2.0, < 7.2.2.1 → fixed in 7.2.2.1 • RubyGems actionpack: >= 8.0.0, < 8.0.0.1 → fixed in 8.0.0.1

Description

There is a possible Cross Site Scripting (XSS) vulnerability in the `content_security_policy` helper in Action Pack. Impact ------ Applications which set Content-Security-Policy (CSP) headers dynamically from untrusted user input may be vulnerable to carefully crafted inputs being able to inject new directives into the CSP. This could lead to a bypass of the CSP and its protection against XSS and other attacks. Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- Applications can avoid setting CSP headers dynamically from untrusted input, or can validate/sanitize that input. Credits ------- Thanks to ryotak for the report!

Related

Alias · CVE (1)

  • CVE-2024-54133 Action Pack is a framework for handling and responding to web requests. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References